WhatsApp dice no al iPhone3G obsoleto

Hace unos días contactaron conmigo varias personas para saber cómo solucionar el problema de WhatsApp y el iPhone3G. Únicamente les pude decir que oficialmente no se puede solucionar, ni por parte de Apple ni por parte de los desarrolladores de WhatsApp.

Tras buscar y buscar me di cuenta que hubieron muchos usuarios afectados por este hecho. La causa es que WhatsApp ha decidido dejar de dar soporte al iPhone3G o anteriores al iPhone4. Esto provoca que miles y miles de usuarios que estaban muy contentos con su smartphone, ahora desearían obtener el nuevo modelo o, en muchos otros casos, cambiar a Android.

Esta decisión no ha sido única de WhatsApp, otros grandes del mundillo como Line también han dejado de dar soporte al iPhone3G. Como ellas hay cientos en estos momentos.
Hemos de tener en cuenta que este smartphone de Apple lleva en el mercado más de 5 años y es un aspecto que para los usuarios no significa que se acabe su periodo de vida. Al contrario que Apple, intentando que el usuario se deshaga de él.

Si comparamos con Android vemos una diferencia muy importante en este aspecto. En la Play Store de Google podemos encontrar la misma aplicación con diferentes versiones para multitud de dispositivos. Da igual que tu sistema lleve sin actualizar años, tu aplicación con la versión correspondiente la encontrarás para instalártela. Y un valor añadido es, que muchas de ellas las encontrarás gratis y con la misma funcionalidad.

Otro dato importante que he visto durante estas semana son las ventas del nuevo iPhone 5. No han colado tan bien en el mercado y Apple ha frenado la producción del mismo.

Desde fuera y leyendo noticias diariamente, mi punto de vista es el siguiente. Después de conocer las bajas ventas del iPhone 5 (calculadas internamente) deciden sacar beneficio de la obsolescencia programada y darle un gran empujón dejando de dar soporte al sistema iOS 4.2.1 y con ello provocan el segundo gran empujón, obligan a los grandes desarrolladores a hacer lo mismo. De igual manera, los desarrolladores tampoco ponen a disposición la versión compatible con el iPhone3G.

Después de ponerme en contacto con soporte de WhatsApp me contestan lanzando balones fuera como que he de actualizar a una versión de iOS4.3, actualizar por iTunes, etc. Cosas obvias que no son posibles en el iPhone3G por orden de Apple.

Contacto con ellos una segunda vez insistiéndoles y dándole los detalles exactos que ellos ya saben para que me den una respuesta más concienzuda. Su respuesta fue esta:

Para que WhatsApp sea capaz de proveer un servicio seguro y fiable para todos nuestros usuarios, simplemente no podemos ofrecer soporte para versiones anteriores de la aplicación. Si tienes la versión 2.8.4 de WhatsApp Messenger en un iPhone 3G con iOS 4.2.1, todavía podrás usar WhatsApp con el mismo número de teléfono. Desafortunadamente, Apple no nos deja ninguna manera de proporcionar versiones anteriores de la aplicación, así que si no descargaste la versión 2.8.4 anteriormente no hay manera de descargarlo ahora.
WhatsApp es un servicio basado en el Internet. Requiere que todos los dispositivos que conectan a la red de WhatsApp usen el mismo protocolo (igual como si todos estuvieran hablando el mismo idioma). Debido a que nuestro protocolo va desarrollándose, agregando nuevas funciones y mejorando la seguridad y compatibilidad, es esencial que todos los dispositivos usando WhatsApp empiezan a usar el nuevo protocolo. Si todos los dispositivos no usan el nuevo protocolo, nuestro sistema queda vulnerable a usuarios que abusan al sistema tras ataques y propaganda. Si permitimos que dispositivos antiguos permanezcan en el sistema, esos pocos usuarios con dispositivos antiguos arriesgan la experiencia para los demás usuarios. Con tiempo, el protocolo se desarrollará a un nivel en que dispositivos antiguos simplemente no podrán entender al nuevo protocolo.

Le echan la culpa a las nuevas funciones, mejoras en la seguridad y por último, a la compatibilidad. ¿Vosotros habéis notado alguna función nueva, mejora de seguridad o compatibilidad? No.
Lo más gracioso ha sido como ha terminado el email. No he podido evitar reírme:

En fin, la explicación no es tan sencillo como “tu dispositivo es demasiado antiguo”, sin embargo, esa explicación es la realidad.

Podéis encontrar diferentes maneras o intentos por internet de hacer funcionar el WhatsApp en vuestros iPhone3G pero no a todos les funciona. Por ejemplo, desde iPhonea2.com nos explican un par de métodos para intentar hacerlo funcionar. Uno es recibiendo un alto número de mensajes por WhatsApp de tus contactos y la otra engañando al propio sistema haciéndole creer que dispone del iOS 4.3.

¿Es esta la manera que tiene Apple de seguir vendiendo? ¿Es esta su política? ¿Comprarás el nuevo iPhone? A mi no me convencía, no me convence y ya veremos si lo hace en un futuro. Y por supuesto, tampoco la de los desarrolladores dejando de lado a todos los usuarios.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *